Personal Software Inspector: Requirements

Free Security Software

Requirements

Supported Operating Systems (32 & 64 bit)

Microsoft Windows 10
Microsoft Windows 8.1
Microsoft Windows 8
Microsoft Windows 7
Microsoft Windows Vista SP 1 or later

Privileges

To install and run PSI you require administrative privileges.

Connectivity

Access to Flexera Software's encrypted servers via SSL (https://psi.secunia.com:443/) and access to Microsoft Windows Update servers, see also Software Requirements below

Software Requirements

The latest version of Microsoft Update. You can determine whether or not you are running the latest version by visiting update.microsoft.com with Microsoft Internet Explorer, while logged in as the Administrator. If you are able to check your system for missing updates through this tool, your system should function properly with PSI.

Hardware Requirements

There are no additional hardware requirements. If your computer runs any of the above mentioned Operating Systems, then PSI should work.

Back to Personal Software Inspector